Trikarus uses Python 3.7 scripts. Before using Raspbian buster release the stretch version was used. It did not include Python 3.7, but Python 3.5

Fixes

(info) might be obsolete

ln -s /usr/share/pyshared/lsb_release.py /usr/local/lib/python3.7/site-packages/lsb_release.py

Reconfigure environment

cd /usr/bin
ln -sf /usr/local/bin/pip3.7 pip3

Install required libraries for Trikarus

pip3.7 install collectd
pip3.7 install gevent_ticker
pip3.7 install influxdb
pip3.7 install numpy
pip3.7 install smbus
pip3.7 install smbus2
pip3.7 install systemd
pip3.7 install pigpio
pip3.7 install pigpio_encoder
pip3.7 install pyserial
pip3.7 install RPi.GPIO
pip3.7 install websockets
  • No labels
Write a comment…